Ruby on Rails Tuesday, April 18, 2017
I'm trying to update a ruby on rails app from 4.2 to 5.0 version.
I'm following this guide https://hashrocket.com/blog/posts/how-to-upgrade-to-rails-5 and when i run $ bundle update rails I have the following error:
Bundler could not find compatible versions for gem "activerecord":
audited-activerecord was resolved to 4.2.2, which depends on
activerecord (~> 4.0)
rails (< 5.1, >= 5.0.0.rc2) was resolved to 5.0.0.rc2, which depends on
activerecord (= 5.0.0.rc2)
I'm aware that it might appear some problems related to gems' dependencies, however I can't find out a solution to this problem, since . Can you help me?
Thank you in advance!
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to email@example.com.
To post to this group, send email to firstname.lastname@example.org.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/a495c69b-caf3-4caa-895e-dbe255dab0ab%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Posted by Ruby on Rails at 3:24 AM